Catch up on everything announced at Firebase Summit, and learn how Firebase can help you accelerate app development and run your app with confidence. Learn More

העבר אל Go Admin SDK v4

קל לארגן דפים בעזרת אוספים אפשר לשמור ולסווג תוכן על סמך ההעדפות שלך.

החל מגרסה 4.0.0, Firebase Admin SDK for Go הצטרף למודולי Go . כמו כן, ישנם שינויים פורצים בטיפול בשגיאות ובסמנטיקה.

שינויים בהתקנה

בהתאם לשיטות העבודה המומלצות של המודולים , הגרסה העיקרית של ה-SDK צורפה לשם החבילה. שינוי זה מביא לעדכוני שם החבילה הבאים:

  • firebase.google.com/go → firebase.google.com/go/v4
  • firebase.google.com/go/auth → firebase.google.com/go/v4/auth
  • firebase.google.com/go/db → firebase.google.com/go/v4/db
  • firebase.google.com/go/iid → firebase.google.com/go/v4/iid
  • firebase.google.com/go/messaging → firebase.google.com/go/v4/messaging

מפתחים כבר משתמשים במודולים

השתמש בשם החבילה עם הגרסה כדי להתקין את הגרסה האחרונה של ה-SDK.

go get firebase.google.com/go/v4

יש להשתמש באותו שם חבילה עם גרסה בקוד המקור בעת ייבוא ​​ה-SDK.

package helloworld

import (
        "firebase.google.com/go/v4"
        "firebase.google.com/go/v4/auth"
        "firebase.google.com/go/v4/messaging"
)

כדי להתקין גרסה קודמת, השתמש בשם החבילה הישן (ללא גרסה) עם הגדרת גרסה מפורשת.

# Notice the @v3 suffix.
# This instructs Go tools to fetch the latest v3.x release of the SDK.
go get firebase.google.com/go@v3

מפתחים שאינם משתמשים כעת במודולים

מפתחים שעדיין לא הצטרפו למודולים יכולים להמשיך להתקין את ה-SDK באמצעות שם החבילה ללא גרסה.

go get firebase.google.com/go

עם זאת, שים לב שזה מביא את הגרסה האחרונה של ה-SDK (v4 ואילך) המכילה שינויים אחרים ב-API.

שינויים כלליים בטיפול בשגיאות

ה-v4 SDK מציג חבילת errorutils חדשה המספקת פונקציות לטיפול במצבי שגיאה ברמת הפלטפורמה. במקרה ששגיאה נגרמה על ידי שגיאת שירות אחורי, תוכל לגשת לתגובת השגיאה המקורית על ידי קריאה לפונקציה החדשה errorutils.HTTPResponse() . אתה יכול להשתמש בפונקציות בחבילה זו עם שגיאות המוחזרות על ידי כל API ב-SDK.

שינויים ב-API של אימות

  • נוספו פונקציות חדשות לטיפול בשגיאות לשימוש בשילוב עם ממשקי API של VerifyIDToken() ו- VerifySessionCookie() :
    • IsIDTokenInvalid()
    • IsIDTokenExpired()
    • IsSessionCookieInvalid()
    • IsSessionCookieExpired()
    • IsCertificateFetchFailed()
  • הוצא משימוש:
    • IsProjectNotFound()
    • IsUnknown()
    • IsInsufficientPermission()
    • IsInvalidEmail()

שינויים ב-FCM API

  • שונה שם הסוג messaging.WebpushFCMOptions ל- messaging.WebpushFcmOptions .
  • נוסף:
    • IsThirdPartyAuthError()
    • IsQuotaExceeded()
    • IsSenderIDMismatch()
    • IsUnregistered()
    • IsUnavailable()
  • הוצא משימוש:
    • IsInvalidAPNSCredentials()
    • IsMessageRateExceeded()
    • IsMismatchedCredential()
    • IsRegistrationTokenNotRegistered()
    • IsServerUnavailable()
    • IsTooManyTopics()
    • IsUnknown()

שינויים ב-IID API

כל פונקציות הטיפול בשגיאות הזמינות כעת בחבילת iid הוצאו משימוש. השתמש במקום זאת בפונקציות הטיפול בשגיאות המתאימות הניתנות בחבילת errorutils .