Google is committed to advancing racial equity for Black communities. See how.
Diese Seite wurde von der Cloud Translation API übersetzt.
Switch to English

Untergeordnete Knoten begrenzen

Feuerbasis
Hergestellt von Firebase

Begrenzt die Anzahl der Knoten auf eine angegebene maximale Anzahl in einem angegebenen Echtzeitdatenbankpfad.

Wie diese Erweiterung funktioniert

Verwenden Sie diese Erweiterung, um die maximale Anzahl von Knoten zu steuern, die in einem Firebase-Echtzeitdatenbankpfad gespeichert sind.

Wenn die Anzahl der Knoten in Ihrem angegebenen Echtzeitdatenbankpfad die angegebene maximale Anzahl überschreitet, löscht diese Erweiterung die ältesten Knoten zuerst, bis die maximale Anzahl der verbleibenden Knoten vorhanden ist.

Zusätzliches Setup

Stellen Sie vor der Installation dieser Erweiterung sicher, dass Sie in Ihrem Firebase-Projekt eine Echtzeitdatenbankinstanz eingerichtet haben .

Abrechnung

Diese Erweiterung verwendet andere Firebase- oder Google Cloud Platform-Dienste, für die möglicherweise Gebühren anfallen:

  • Firebase-Echtzeitdatenbank
  • Cloud-Funktionen

Wenn Sie Firebase-Erweiterungen verwenden, werden Ihnen nur die zugrunde liegenden Ressourcen berechnet, die Sie verwenden. Ein kostenpflichtiger Abrechnungsplan ist nur erforderlich, wenn die Erweiterung einen Dienst verwendet, für den ein kostenpflichtiger Tarif erforderlich ist, z. B. das Aufrufen einer Google Cloud Platform-API oder ausgehende Netzwerkanforderungen an Dienste, die nicht von Google stammen. Alle Firebase-Dienste bieten eine kostenlose Nutzungsstufe. Erfahren Sie mehr über die Firebase-Abrechnung.

So installieren Sie diese Erweiterung

Verwenden der Firebase-Konsole

Zum Installieren und Verwalten von Erweiterungen können Sie die Firebase-Konsole verwenden.

Installation über die Konsole

Verwenden der Firebase-CLI

Zum Installieren und Verwalten von Erweiterungen können Sie auch die Firebase-CLI verwenden:

Schritt 1: Führen Sie den folgenden Befehl npm aus , um die CLI zu installieren oder auf die neueste CLI-Version zu aktualisieren.

npm install -g firebase-tools
Funktioniert nicht Sehen Sie sich die Firebase-CLI-Referenz an oder ändern Sie Ihre npm-Berechtigungen .

Schritt 2: Installieren Sie diese Erweiterung, indem Sie den folgenden Befehl ausführen

firebase ext:install rtdb-limit-child-nodes --project= projectId_or_alias 
Unterstützt
Echtzeitdatenbank
Autor
Lizenz
Apache-2.0
Ausführung
0.1.0