Catch up on everything announced at Firebase Summit, and learn how Firebase can help you accelerate app development and run your app with confidence. Learn More

Google Play পরিষেবাগুলিতে Firebase Android SDK-এর নির্ভরতা

সেভ করা পৃষ্ঠা গুছিয়ে রাখতে 'সংগ্রহ' ব্যবহার করুন আপনার পছন্দ অনুযায়ী কন্টেন্ট সেভ করুন ও সঠিক বিভাগে রাখুন।

কিছু ফায়ারবেস অ্যান্ড্রয়েড SDK Google Play পরিষেবাগুলির উপর নির্ভর করে, যার মানে তারা শুধুমাত্র Google Play পরিষেবা ইনস্টল থাকা ডিভাইস এবং এমুলেটরগুলিতে চলবে৷ এই Firebase SDKগুলি আপনার অ্যাপে একটি সুরক্ষিত, আপ-টু-ডেট এবং হালকা API প্রদান করতে ডিভাইসে Google Play পরিষেবার ব্যাকগ্রাউন্ড পরিষেবার সাথে যোগাযোগ করে। কিছু কিছু অ্যান্ড্রয়েড ডিভাইস, যেমন অ্যামাজন কিন্ডল ফায়ার ডিভাইস বা কিছু অঞ্চলে বিক্রি হওয়া ডিভাইসগুলিতে Google Play পরিষেবা ইনস্টল করা নেই।

কোন Firebase Android SDK-এর জন্য Google Play পরিষেবার প্রয়োজন হয়?

Firebase SDK গুলিকে তিনটি বিভাগে ভাগ করা যেতে পারে:

  • প্লে পরিষেবাগুলি প্রয়োজন — এই SDKগুলির জন্য Google Play পরিষেবাগুলির প্রয়োজন, অন্যথায় তাদের কোনও কার্যকারিতা নেই৷
  • প্লে পরিষেবাগুলি প্রস্তাবিত — এই SDKগুলির জন্য Google Play পরিষেবাগুলির সম্পূর্ণ কার্যকারিতা থাকা প্রয়োজন, তবে তারা এখনও Google Play পরিষেবাগুলি ছাড়াই বেশিরভাগ কার্যকারিতা অফার করে৷
  • প্লে পরিষেবাগুলির প্রয়োজন নেই — এই SDKSগুলির সম্পূর্ণ কার্যকারিতা থাকতে Google Play পরিষেবাগুলির প্রয়োজন নেই৷

নীচের সারণীগুলি শুধুমাত্র প্রতিটি SDK-এর সর্বশেষ প্রকাশের জন্য সঠিক। কিছু পুরানো সংস্করণের কঠোর প্রয়োজনীয়তা থাকতে পারে।

Google Play পরিষেবার প্রয়োজন নেই

পণ্য লাইব্রেরি গুগল প্লে পরিষেবা?
অ্যাপ কাস্টম এবং ডিবাগ প্রদানকারী চেক করুন com.google.firebase:firebase-appcheck:16.1.0
com.google.firebase:firebase-appcheck-ktx:16.1.0
com.google.firebase:firebase-appcheck-debug:16.1.0
আবশ্যক না
অ্যাপ বিতরণ API com.google.firebase:firebase-appdistribution-api:16.0.0-beta05
com.google.firebase:firebase-appdistribution-api-ktx:16.0.0-beta05
আবশ্যক না
অ্যাপ বিতরণ com.google.firebase:firebase-appdistribution:16.0.0-beta05 আবশ্যক না
প্রমাণীকরণ com.google.firebase:firebase-auth:21.1.0
com.google.firebase:firebase-auth-ktx:21.1.0
আবশ্যক না
ক্লাউড ফায়ারস্টোর com.google.firebase:firebase-firestore:24.4.1
com.google.firebase:firebase-firestore-ktx:24.4.1
আবশ্যক না
Firebase ক্লায়েন্ট SDK-এর জন্য ক্লাউড ফাংশন com.google.firebase:firebase-functions:20.2.1
com.google.firebase:firebase-functions-ktx:20.2.1
আবশ্যক না
ফায়ারবেসের জন্য ক্লাউড স্টোরেজ com.google.firebase:firebase-storage:20.1.0
com.google.firebase:firebase-storage-ktx:20.1.0
আবশ্যক না
ক্র্যাশলাইটিক্স com.google.firebase:firebase-crashlytics:18.3.2
com.google.firebase:firebase-crashlytics-ktx:18.3.2
আবশ্যক না
ইন-অ্যাপ মেসেজিং com.google.firebase:firebase-inappmessaging:20.2.0
com.google.firebase:firebase-inappmessaging-ktx:20.2.0
আবশ্যক না
ইন-অ্যাপ মেসেজিং ডিসপ্লে com.google.firebase:firebase-inappmessaging-display:20.2.0
com.google.firebase:firebase-inappmessaging-display-ktx:20.2.0
আবশ্যক না
ফায়ারবেস ইনস্টলেশন com.google.firebase:firebase-installations:17.1.0
com.google.firebase:firebase-installations-ktx:17.1.0
আবশ্যক না
কর্মক্ষমতা নিরীক্ষণ com.google.firebase:firebase-perf:20.3.0
com.google.firebase:firebase-perf-ktx:20.3.0
আবশ্যক না
রিয়েলটাইম ডাটাবেস com.google.firebase:firebase-database:20.1.0
com.google.firebase:firebase-database-ktx:20.1.0
আবশ্যক না
দূরবর্তী কনফিগারেশন com.google.firebase:firebase-config:21.2.0
com.google.firebase:firebase-config-ktx:21.2.0
আবশ্যক না
পণ্য লাইব্রেরি গুগল প্লে পরিষেবা?
AdMob com.google.android.gms:play-services-ads:21.3.0 প্রস্তাবিত*
বিশ্লেষণ com.google.firebase:firebase-analytics:21.2.0
com.google.firebase:firebase-analytics-ktx:21.2.0
প্রস্তাবিত*
অ্যাপ চেক প্লে ইন্টিগ্রিটি প্রদানকারী com.google.firebase:firebase-appcheck-playintegrity:16.1.0 প্রয়োজন
অ্যাপ চেক SafetyNet প্রদানকারী com.google.firebase:firebase-appcheck-safetynet:16.1.0 প্রয়োজন
অ্যাপ ইন্ডেক্সিং com.google.firebase:firebase-appindexing:20.0.0 প্রয়োজন
ক্লাউড মেসেজিং com.google.firebase:firebase-messaging:23.1.0
com.google.firebase:firebase-messaging-ktx:23.1.0
প্রয়োজন
ডাইনামিক লিংক com.google.firebase:firebase-dynamic-links:21.1.0
com.google.firebase:firebase-dynamic-links-ktx:21.1.0
প্রয়োজন
ফায়ারবেস এমএল ভিশন com.google.firebase:firebase-ml-vision:24.1.0 প্রয়োজন
Firebase ML কাস্টম মডেল com.google.firebase:firebase-ml-model-interpreter:22.0.4 প্রয়োজন

* Google Analytics-এর জন্য Firebase SDK যেকোনো ডিভাইসে ইভেন্ট পাঠাতে পারে, কিন্তু কিছু স্বয়ংক্রিয় অন্তর্দৃষ্টি যেমন ডেমোগ্রাফিক্স শুধুমাত্র Google Play পরিষেবার ডিভাইসে উপলব্ধ।