Catch up on everything announced at Firebase Summit, and learn how Firebase can help you accelerate app development and run your app with confidence. Learn More

Google Play सेवाओं पर Firebase Android SDK की निर्भरता

संग्रह की मदद से व्यवस्थित रहें अपनी प्राथमिकताओं के आधार पर, कॉन्टेंट को सेव करें और कैटगरी में बांटें.

कुछ फायरबेस एंड्रॉइड एसडीके Google Play सेवाओं पर निर्भर करते हैं, जिसका अर्थ है कि वे केवल उन उपकरणों और एमुलेटर पर चलेंगे जिनमें Google Play सेवाएं स्थापित हैं। ये फायरबेस एसडीके आपके ऐप को एक सुरक्षित, अप-टू-डेट और लाइटवेट एपीआई प्रदान करने के लिए डिवाइस पर Google Play सेवाओं की पृष्ठभूमि सेवा के साथ संचार करते हैं। कुछ Android डिवाइस, जैसे Amazon Kindle Fire डिवाइस या जो कुछ क्षेत्रों में बेचे जाते हैं, उनमें Google Play सेवाएं इंस्टॉल नहीं होती हैं।

किन Firebase Android SDK को Google Play सेवाओं की आवश्यकता है?

फायरबेस एसडीके को तीन श्रेणियों में विभाजित किया जा सकता है:

  • Play सेवाओं की आवश्यकता - इन SDK को Google Play सेवाओं की आवश्यकता होती है, अन्यथा उनकी कोई कार्यक्षमता नहीं होती है।
  • अनुशंसित प्ले सेवाएं - इन एसडीके के लिए Google Play सेवाओं की पूर्ण कार्यक्षमता की आवश्यकता होती है, लेकिन वे अभी भी Google Play सेवाओं के बिना भी अधिकांश कार्यक्षमता प्रदान करते हैं।
  • Play सेवाओं की आवश्यकता नहीं है - इन SDKS को Google Play सेवाओं की पूर्ण कार्यक्षमता की आवश्यकता नहीं है।

नीचे दी गई तालिकाएं केवल प्रत्येक SDK की नवीनतम रिलीज़ के लिए सटीक हैं। कुछ पुराने संस्करणों की सख्त आवश्यकताएं हो सकती हैं।

Google Play सेवाओं की आवश्यकता नहीं है

उत्पाद पुस्तकालय Google Play सेवाएं?
ऐप चेक कस्टम और डीबग प्रदाता com.google.firebase:firebase-appcheck:16.1.0
com.google.firebase:firebase-appcheck-ktx:16.1.0
com.google.firebase:firebase-appcheck-debug:16.1.0
आवश्यक नहीं
ऐप वितरण एपीआई com.google.firebase:firebase-appdistribution-api:16.0.0-beta05
com.google.firebase:firebase-appdistribution-api-ktx:16.0.0-beta05
आवश्यक नहीं
ऐप वितरण com.google.firebase:firebase-appdistribution:16.0.0-beta05 आवश्यक नहीं
प्रमाणीकरण com.google.firebase:firebase-auth:21.1.0
com.google.firebase:firebase-auth-ktx:21.1.0
आवश्यक नहीं
क्लाउड फायरस्टोर com.google.firebase:firebase-firestore:24.4.1
com.google.firebase:firebase-firestore-ktx:24.4.1
आवश्यक नहीं
फायरबेस क्लाइंट एसडीके के लिए क्लाउड फ़ंक्शंस com.google.firebase:firebase-functions:20.2.1
com.google.firebase:firebase-functions-ktx:20.2.1
आवश्यक नहीं
फायरबेस के लिए क्लाउड स्टोरेज com.google.firebase:firebase-storage:20.1.0
com.google.firebase:firebase-storage-ktx:20.1.0
आवश्यक नहीं
Crashlytics com.google.firebase:firebase-crashlytics:18.3.2
com.google.firebase:firebase-crashlytics-ktx:18.3.2
आवश्यक नहीं
इन-ऐप मैसेजिंग com.google.firebase:firebase-inappmessaging:20.2.0
com.google.firebase:firebase-inappmessaging-ktx:20.2.0
आवश्यक नहीं
इन-ऐप मैसेजिंग डिस्प्ले com.google.firebase:firebase-inappmessaging-display:20.2.0
com.google.firebase:firebase-inappmessaging-display-ktx:20.2.0
आवश्यक नहीं
फायरबेस प्रतिष्ठान com.google.firebase:firebase-स्थापना:17.1.0
com.google.firebase:firebase-स्थापना-ktx:17.1.0
आवश्यक नहीं
प्रदर्शन की निगरानी com.google.firebase:firebase-perf:20.3.0
com.google.firebase:firebase-perf-ktx:20.3.0
आवश्यक नहीं
रीयलटाइम डेटाबेस com.google.firebase:firebase-डेटाबेस:20.1.0
com.google.firebase:firebase-डेटाबेस-ktx:20.1.0
आवश्यक नहीं
दूरस्थ विन्यास com.google.firebase:firebase-config:21.2.0
com.google.firebase:firebase-config-ktx:21.2.0
आवश्यक नहीं
उत्पाद पुस्तकालय Google Play सेवाएं?
AdMob com.google.android.gms:play-services-ads:21.3.0 अनुशंसित*
एनालिटिक्स com.google.firebase:firebase-analytics:21.2.0
com.google.firebase:firebase-analytics-ktx:21.2.0
अनुशंसित*
ऐप चेक प्ले इंटीग्रिटी प्रोवाइडर com.google.firebase:firebase-appcheck-playintegrity:16.1.0 आवश्यक
ऐप चेक सेफ्टीनेट प्रदाता com.google.firebase:firebase-appcheck-safetynet:16.1.0 आवश्यक
ऐप इंडेक्सिंग com.google.firebase:firebase-appindexing:20.0.0 आवश्यक
क्लाउड मैसेजिंग com.google.firebase:firebase-messaging:23.1.0
com.google.firebase:firebase-messaging-ktx:23.1.0
आवश्यक
गतिशील लिंक com.google.firebase:firebase-गतिशील-लिंक:21.1.0
com.google.firebase:firebase-dynamic-links-ktx:21.1.0
आवश्यक
फायरबेस एमएल विजन com.google.firebase:firebase-ml-vision:24.1.0 आवश्यक
फायरबेस एमएल कस्टम मॉडल com.google.firebase:firebase-ml-model-interpreter:22.0.4 आवश्यक

* Google Analytics के लिए Firebase SDK किसी भी उपकरण पर ईवेंट भेज सकता है, लेकिन कुछ स्वचालित जानकारियां जैसे जनसांख्यिकी केवल Google Play सेवाओं वाले उपकरणों पर उपलब्ध हैं।