Catch up on everything announced at Firebase Summit, and learn how Firebase can help you accelerate app development and run your app with confidence. Learn More

Firebase Android SDK 對 Google Play 服務的依賴

透過集合功能整理內容 你可以依據偏好儲存及分類內容。

一些 Firebase Android SDK 依賴於Google Play 服務,這意味著它們只能在安裝了 Google Play 服務的設備和模擬器上運行。這些 Firebase SDK 與設備上的 Google Play 服務後台服務通信,為您的應用提供安全、最新且輕量級的 API。某些 Android 設備(例如 Amazon Kindle Fire 設備或在某些地區銷售的設備)未安裝 Google Play 服務。

哪些 Firebase Android SDK 需要 Google Play 服務?

Firebase SDK 可以分為三類:

  • 需要 Play 服務——這些 SDK 需要 Google Play 服務,否則它們沒有任何功能。
  • 推薦的 Play 服務——這些 SDK 需要 Google Play 服務才能具備全部功能,但即使沒有 Google Play 服務,它們仍能提供大部分功能。
  • 不需要 Play 服務——這些 SDK 不需要 Google Play 服務來提供完整的功能。

下表僅適用於每個 SDK 的最新版本。一些舊版本可能有更嚴格的要求。

不需要Google Play 服務

產品圖書館谷歌播放服務?
App Check 自定義和調試提供程序com.google.firebase:firebase-appcheck:16.1.0
com.google.firebase:firebase-appcheck-ktx:16.1.0
com.google.firebase:firebase-appcheck-debug:16.1.0
不需要
應用程序分發 API com.google.firebase:firebase-appdistribution-api:16.0.0-beta05
com.google.firebase:firebase-appdistribution-api-ktx:16.0.0-beta05
不需要
應用分發com.google.firebase:firebase-appdistribution:16.0.0-beta05不需要
驗證com.google.firebase:firebase-auth:21.1.0
com.google.firebase:firebase-auth-ktx:21.1.0
不需要
雲端 Firestore com.google.firebase:firebase-firestore:24.4.1
com.google.firebase:firebase-firestore-ktx:24.4.1
不需要
Firebase 客戶端 SDK 的雲函數com.google.firebase:firebase-functions:20.2.1
com.google.firebase:firebase-functions-ktx:20.2.1
不需要
用於 Firebase 的雲存儲com.google.firebase:firebase-storage:20.1.0
com.google.firebase:firebase-storage-ktx:20.1.0
不需要
崩潰分析com.google.firebase:firebase-crashlytics:18.3.2
com.google.firebase:firebase-crashlytics-ktx:18.3.2
不需要
應用內消息com.google.firebase:firebase-inappmessaging:20.2.0
com.google.firebase:firebase-inappmessaging-ktx:20.2.0
不需要
應用內消息顯示com.google.firebase:firebase-inappmessaging-display:20.2.0
com.google.firebase:firebase-inappmessaging-display-ktx:20.2.0
不需要
Firebase 安裝com.google.firebase:firebase 安裝:17.1.0
com.google.firebase:firebase-installations-ktx:17.1.0
不需要
性能監控com.google.firebase:firebase-perf:20.3.0
com.google.firebase:firebase-perf-ktx:20.3.0
不需要
實時數據庫com.google.firebase:firebase-數據庫:20.1.0
com.google.firebase:firebase-數據庫-ktx:20.1.0
不需要
遠程配置com.google.firebase:firebase-config:21.2.0
com.google.firebase:firebase-config-ktx:21.2.0
不需要
產品圖書館谷歌播放服務?
AdMob com.google.android.gms:play-services-ads:21.3.0推薦的*
分析com.google.firebase:firebase-analytics:21.2.0
com.google.firebase:firebase-analytics-ktx:21.2.0
推薦的*
App Check Play 完整性提供商com.google.firebase:firebase-appcheck-playintegrity:16.1.0必需的
App Check SafetyNet 提供商com.google.firebase:firebase-appcheck-safetynet:16.1.0必需的
應用索引com.google.firebase:firebase-appindexing:20.0.0必需的
雲消息com.google.firebase:firebase-消息:23.1.0
com.google.firebase:firebase-messaging-ktx:23.1.0
必需的
動態鏈接com.google.firebase:firebase-動態鏈接:21.1.0
com.google.firebase:firebase-動態鏈接-ktx:21.1.0
必需的
Firebase 機器學習視覺com.google.firebase:firebase-ml-vision:24.1.0必需的
Firebase ML 自定義模型com.google.firebase:firebase-ml-model-interpreter:22.0.4必需的

* 適用於 Google Analytics 的 Firebase SDK 可以在任何設備上發送事件,但某些自動洞察(例如人口統計數據)僅適用於具有 Google Play 服務的設備。