প্রধান মডিউলগুলিতে সুইফ্ট এক্সটেনশন API ব্যবহার করতে মাইগ্রেট করুন

সুইফট-নেটিভ এপিআই আরও বিস্তৃতভাবে উপলব্ধ করতে এবং ভবিষ্যতে নতুন সুইফ্ট ভাষা বৈশিষ্ট্য সমর্থন করার ক্ষমতা বাড়াতে আমরা আমাদের সুইফ্ট এক্সটেনশন SDK গুলিকে মূল SDK-তে মার্জ করছি৷ আমরা যে পরিবর্তনগুলি করছি এবং আপনার প্রকল্পগুলিতে তাদের প্রত্যাশিত প্রভাবগুলি নীচে নথিভুক্ত করা হয়েছে৷

কি পরিবর্তন হচ্ছে?

Apple SDK 10.17.0-এর জন্য Firebase দিয়ে শুরু করে, সুইফ্ট এক্সটেনশন SDK গুলিকে তাদের সংশ্লিষ্ট প্রধান SDK-তে মার্জ করা হয়েছে৷ উদাহরণস্বরূপ, FirebaseFirestoreSwift মডিউল থেকে সমস্ত API FirebaseFirestore এ যোগ করা হয়েছে, তাই সেই APIগুলি অ্যাক্সেস করতে আপনাকে আর FirebaseFirestoreSwift মডিউল আমদানি করতে হবে না।

যেহেতু সমস্ত সুইফ্ট এক্সটেনশন এখন প্রধান মডিউলের অংশ, তাই এক্সটেনশন SDK-এর আর প্রয়োজন নেই, এবং অবহেলিত হয়েছে৷ সুইফ্ট এক্সটেনশন SDK গুলি সহ বা ব্যবহার করা একটি কম্পাইলার সতর্কতা জাগিয়ে তুলবে এবং ফেব্রুয়ারি 2024 এর প্রথম দিকে, আমরা সুইফট এক্সটেনশনগুলি সম্পূর্ণরূপে প্রকাশ করা বন্ধ করে দেব।

★ দ্রষ্টব্য: সুইফ্ট এক্সটেনশনগুলির বর্তমানে বা পূর্বে প্রকাশিত সংস্করণগুলি এখনও কাজ করবে৷ যাইহোক, আমরা সুপারিশ করছি যে আপনি আপনার অ্যাপটিকে মূল মডিউল থেকে সুইফ্ট এপিআই ব্যবহার করতে স্থানান্তরিত করুন যাতে আপনি সংশোধন করা চালিয়ে যান এবং পরিবর্তন এবং নতুন বৈশিষ্ট্যগুলির সুবিধা নিতে পারেন।

এই পরিবর্তনের জন্য গুরুত্বপূর্ণ তারিখ

2023 সালের অক্টোবরে

সুইফ্ট এক্সটেনশন SDKগুলিকে প্রধান SDK-তে একত্রিত করা হয়েছে এবং তারপরে প্রধান SDK-এর অনুকূলে অবমূল্যায়িত করা হয়েছে৷ এই পরিবর্তন ঘোষণা করে সংস্করণ 10.17.0 এর জন্য রিলিজ নোট দেখুন।

আপনি এখন প্রধান SDK মডিউল থেকে সরাসরি সুইফট এক্সটেনশন SDK API ব্যবহার করতে পারেন। পরবর্তী বড় সংস্করণ প্রকাশ না হওয়া পর্যন্ত এক্সটেনশন SDK-এর ব্যবহার এখনও সম্ভব কিন্তু ব্যবহার করার সময় অবচয় সতর্কতা জারি করবে।

ফেব্রুয়ারী 2024 এর প্রথম দিকে

আমরা সুইফট এক্সটেনশনের নতুন সংস্করণ প্রকাশ করা বন্ধ করে দেব এবং আমরা Firebase-এর Package.swift থেকে সুইফট এক্সটেনশনগুলি সরিয়ে দেব। পুরানো সংস্করণগুলি কাজ করতে থাকবে তবে আপডেটগুলি পাবে না।

মূল মডিউল থেকে সুইফট-নেটিভ এপিআই ব্যবহার করার জন্য কীভাবে স্থানান্তর করবেন

আপনি যদি বর্তমানে সুইফ্ট এক্সটেনশন SDK ব্যবহার না করেন তাহলে কোনো পদক্ষেপের প্রয়োজন নেই। আপনি যদি একটি সুইফট এক্সটেনশন SDK ব্যবহার করেন, তাহলে আপনার প্রকল্পে নিম্নলিখিত পরিবর্তনগুলি করুন৷

কর্মক্ষেত্র পরিবর্তন

সুইফট প্যাকেজ ম্যানেজার

Firebase 10.17.0+ সংস্করণে আপডেট করার পর, আপনার টার্গেটের সেটিংসের সাধারণ ট্যাবে ফ্রেমওয়ার্ক, লাইব্রেরি এবং এম্বেড করা বিষয়বস্তু বিভাগে নেভিগেট করুন এবং সুইফ্ট এক্সটেনশন SDK (যেমন FirebaseFirestoreSwift ) সরিয়ে দিন।

কোকোপডস

Firebase 10.17.0+ সংস্করণে আপডেট করার পরে, আপনার Podfile-এ নেভিগেট করুন এবং আপনার লক্ষ্যের জন্য ফ্রেমওয়ার্ক বিভাগ যোগ করার জন্য আপনার প্রকল্পের নির্ভরতার সাথে সম্পর্কিত লাইনটি সরিয়ে দিন এবং সুইফট এক্সটেনশন SDK (যেমন pod FirebaseFirestoreSwift ) সরিয়ে দিন। তারপর, pod install কমান্ডটি পুনরায় চালান।

জিপ বিতরণ এবং কার্থেজ

ফায়ারবেসকে 10.17.0+ সংস্করণে আপডেট করার পরে, আপনার প্রকল্পের মধ্যে যেকোন সুইফট এক্সটেনশন xcframeworks সরিয়ে ফেলুন (যেমন FirebaseFirestoreSwift.xcframework )।

সোর্স কোড পরিবর্তন

আপনি পূর্বে ব্যবহার করা সুইফ্ট এক্সটেনশন SDKগুলির জন্য, নিম্নলিখিত পদক্ষেপগুলি নিন:

  1. সুইফ্ট এক্সটেনশন SDK উল্লেখ করে কোনো আমদানি বিবৃতি মুছুন। যদি প্রধান SDK আলাদাভাবে আমদানি করা না হয়, তাহলে লাইনের শেষে Swift মুছে দিয়ে আপনাকে মূল SDK আমদানির সাথে সুইফট এক্সটেনশন আমদানি প্রতিস্থাপন করতে হবে।
  2. আপনি যদি কোনো সুইফট এক্সটেনশন SDK প্রকারের উল্লেখ করতে সুইফটের স্পষ্ট-মডিউল নেমস্পেসিং ব্যবহার করেন, তাহলে আপনাকে সংশ্লিষ্ট প্রধান SDK দিয়ে সেগুলি প্রতিস্থাপন করতে হবে। উদাহরণস্বরূপ, FirebaseFirestoreSwift.QueryPredicate নাম পরিবর্তন করে FirebaseFirestore.QueryPredicate করতে হবে।