Catch up on everything announced at Firebase Summit, and learn how Firebase can help you accelerate app development and run your app with confidence. Learn More

Dependencias de los SDK de Android de Firebase en los servicios de Google Play

Organiza tus páginas con colecciones Guarda y categoriza el contenido según tus preferencias.

Algunos SDK de Android de Firebase dependen de los servicios de Google Play , lo que significa que solo se ejecutarán en dispositivos y emuladores con los servicios de Google Play instalados. Estos SDK de Firebase se comunican con el servicio en segundo plano de los servicios de Google Play en el dispositivo para proporcionar una API segura, actualizada y liviana para su aplicación. Ciertos dispositivos Android, como los dispositivos Kindle Fire de Amazon o los que se venden en algunas regiones, no tienen instalados los servicios de Google Play.

¿Qué SDK de Android de Firebase requieren los servicios de Google Play?

Los SDK de Firebase se pueden dividir en tres categorías:

  • Se requieren servicios de Play : estos SDK requieren los servicios de Google Play; de lo contrario, no tienen funcionalidad.
  • Servicios de Play recomendados : estos SDK requieren que los servicios de Google Play tengan una funcionalidad completa , pero aún ofrecen la mayoría de las funciones incluso sin los servicios de Google Play.
  • No se requieren servicios de Play : estos SDKS no requieren que los servicios de Google Play tengan una funcionalidad completa.

Las tablas a continuación son precisas solo para la última versión de cada SDK. Algunas versiones anteriores pueden tener requisitos más estrictos.

Servicios de Google Play no requeridos

Producto Biblioteca ¿Servicios de Google Play?
Proveedores personalizados y de depuración de App Check com.google.firebase:firebase-appcheck:16.1.0
com.google.firebase:firebase-appcheck-ktx:16.1.0
com.google.firebase:firebase-appcheck-debug:16.1.0
No requerido
API de distribución de aplicaciones com.google.firebase:firebase-appdistribution-api:16.0.0-beta05
com.google.firebase:firebase-appdistribution-api-ktx:16.0.0-beta05
No requerido
Distribución de aplicaciones com.google.firebase:firebase-appdistribution:16.0.0-beta05 No requerido
Autenticación com.google.firebase:firebase-auth:21.1.0
com.google.firebase:firebase-auth-ktx:21.1.0
No requerido
Tienda de fuego en la nube com.google.firebase:firebase-firestore:24.4.1
com.google.firebase:firebase-firestore-ktx:24.4.1
No requerido
Cloud Functions para el SDK de cliente de Firebase com.google.firebase:firebase-functions:20.2.1
com.google.firebase:firebase-functions-ktx:20.2.1
No requerido
Almacenamiento en la nube para Firebase com.google.firebase:firebase-almacenamiento:20.1.0
com.google.firebase:firebase-almacenamiento-ktx:20.1.0
No requerido
Crashlytics com.google.firebase:firebase-crashlytics:18.3.2
com.google.firebase:firebase-crashlytics-ktx:18.3.2
No requerido
Mensajería en la aplicación com.google.firebase:firebase-inappmessaging:20.2.0
com.google.firebase:firebase-inappmessaging-ktx:20.2.0
No requerido
Pantalla de mensajería en la aplicación com.google.firebase:firebase-inappmessaging-display:20.2.0
com.google.firebase:firebase-inappmessaging-display-ktx:20.2.0
No requerido
Instalaciones de base de fuego com.google.firebase:firebase-installations:17.1.0
com.google.firebase:firebase-installations-ktx:17.1.0
No requerido
Supervisión del rendimiento com.google.firebase:firebase-perf:20.3.0
com.google.firebase:firebase-perf-ktx:20.3.0
No requerido
Base de datos en tiempo real com.google.firebase:firebase-database:20.1.0
com.google.firebase:firebase-database-ktx:20.1.0
No requerido
Configuración remota com.google.firebase:firebase-config:21.2.0
com.google.firebase:firebase-config-ktx:21.2.0
No requerido
Producto Biblioteca ¿Servicios de Google Play?
AdMob com.google.android.gms:play-services-ads:21.3.0 Recomendado*
Analítica com.google.firebase:firebase-analytics:21.2.0
com.google.firebase:firebase-analytics-ktx:21.2.0
Recomendado*
App Check Play Integridad proveedor com.google.firebase:firebase-appcheck-playintegrity:16.1.0 Requerido
Aplicación Comprobar proveedor de SafetyNet com.google.firebase:firebase-appcheck-safetynet:16.1.0 Requerido
Indexación de aplicaciones com.google.firebase:firebase-appindexing:20.0.0 Requerido
Mensajería en la nube com.google.firebase:firebase-messaging:23.1.1
com.google.firebase:firebase-messaging-ktx:23.1.1
Requerido
Enlaces dinámicos com.google.firebase:firebase-dynamic-links:21.1.0
com.google.firebase:firebase-dynamic-links-ktx:21.1.0
Requerido
Visión de aprendizaje automático de Firebase com.google.firebase:firebase-ml-vision:24.1.0 Requerido
Modelo personalizado de Firebase ML com.google.firebase:firebase-ml-modelo-intérprete:22.0.4 Requerido

* El SDK de Firebase para Google Analytics puede enviar eventos en cualquier dispositivo, pero algunas estadísticas automáticas, como los datos demográficos, solo están disponibles en dispositivos con los servicios de Google Play.