Save the date - Google I/O returns May 18-20. Register to get the most out of the digital experience: Build your schedule, reserve space, participate in Q&As, earn Google Developer profile badges, and more. Register now
Эта страница переведена с помощью Cloud Translation API.
Switch to English

Зависимости Firebase Android SDK от сервисов Google Play

Некоторые SDK Firebase для Android зависят от сервисов Google Play , что означает, что они будут работать только на устройствах и эмуляторах с установленными сервисами Google Play. Эти SDK Firebase взаимодействуют с фоновой службой сервисов Google Play на устройстве, чтобы предоставить вашему приложению безопасный, актуальный и легкий API. На некоторых устройствах Android, таких как устройства Amazon Kindle Fire или устройства, продаваемые в некоторых регионах, не установлены сервисы Google Play.

Для каких SDK Firebase требуются сервисы Google Play?

SDK Firebase можно разделить на три категории:

  • Требуются сервисы Google Play - для этих SDK требуются сервисы Google Play, в противном случае они не работают.
  • Рекомендуются сервисы Play - эти SDK требуют, чтобы сервисы Google Play имели полную функциональность, но они по-прежнему предлагают большую часть функций даже без сервисов Google Play.
  • Сервисы Play не требуются - эти SDKS не требуют, чтобы сервисы Google Play имели полную функциональность.

Приведенные ниже таблицы верны только для последней версии каждого SDK. Некоторые старые версии могут иметь более строгие требования.

Сервисы Google Play не требуются

Продукт Библиотека Сервисы Google Play?
Аутентификация com.google.firebase: firebase-auth: 21.0.0
com.google.firebase: firebase-auth-ktx: 21.0.0
Не требуется
Cloud Firestore com.google.firebase: firebase-firestore: 23.0.0
com.google.firebase: firebase-firestore-ktx: 23.0.0
Не требуется
Облачные функции для клиентского SDK Firebase com.google.firebase: firebase-functions: 20.0.0
com.google.firebase: firebase-functions-ktx: 20.0.0
Не требуется
Облачное хранилище для Firebase com.google.firebase: хранилище firebase: 20.0.0
com.google.firebase: firebase-storage-ktx: 20.0.0
Не требуется
Crashlytics com.google.firebase: firebase-crashlytics: 18.0.0
com.google.firebase: firebase-crashlytics-ktx: 18.0.0
Не требуется
Обмен сообщениями в приложении com.google.firebase: firebase-inappmessaging: 20.0.0
com.google.firebase: firebase-inappmessaging-ktx: 20.0.0
Не требуется
Отображение сообщений в приложении com.google.firebase: firebase-inappmessaging-display: 20.0.0
com.google.firebase: firebase-inappmessaging-display-ktx: 20.0.0
Не требуется
Установки Firebase com.google.firebase: установки firebase: 17.0.0
com.google.firebase: firebase-install-ktx: 17.0.0
Не требуется
Мониторинг производительности com.google.firebase: firebase-perf: 20.0.0
com.google.firebase: firebase-perf-ktx: 20.0.0
Не требуется
База данных в реальном времени com.google.firebase: база данных firebase: 20.0.0
com.google.firebase: firebase-database-ktx: 20.0.0
Не требуется
Удаленная конфигурация com.google.firebase: firebase-config: 21.0.0
com.google.firebase: firebase-config-ktx: 21.0.0
Не требуется
Продукт Библиотека Сервисы Google Play?
AdMob com.google.android.gms: play-services-ads: 20.1.0 Рекомендуемые*
Аналитика com.google.firebase: firebase-analytics: 19.0.0
com.google.firebase: firebase-analytics-ktx: 19.0.0
Рекомендуемые*
Индексирование приложений com.google.firebase: firebase-appindexing: 20.0.0 Обязательный
Обмен сообщениями в облаке com.google.firebase: firebase-сообщениями: 22.0.0
com.google.firebase: firebase-messaging-ktx: 22.0.0
Обязательный
Динамические ссылки com.google.firebase: firebase-dynamic-links: 20.0.0
com.google.firebase: firebase-dynamic-links-ktx: 20.0.0
Обязательный
Firebase ML Vision com.google.firebase: firebase-ml-vision: 24.1.0 Обязательный
Пользовательская модель Firebase ML com.google.firebase: firebase-ml-модель-интерпретатор: 22.0.4 Обязательный

* Firebase SDK для Google Analytics может отправлять события на любом устройстве, но некоторые автоматические аналитические данные, такие как демографические данные, доступны только на устройствах с сервисами Google Play.