Installer Firebase avec Swift Package Manager

À partir de la version 8.0.0 du SDK Firebase iOS, la prise en charge du Swift Package Manager de Firebase n'est plus en version bêta et est généralement disponible. CocoaPods n'est pas requis pour les utilisateurs de Swift Package Manager.

Via Xcode

La prise en charge de Swift Package Manager nécessite Xcode 12.5 ou supérieur.

  1. En cas de migration d'un projet basé sur CocoaPods, exécutez pod deintegrate pour enlever CocoaPods de votre projet Xcode. Le CocoaPods généré .xcworkspace fichier peut être supprimé en toute sécurité après. Si vous ajoutez Firebase à un projet pour la première fois, cette étape peut être ignorée.

  2. Dans Xcode, installez les bibliothèques Firebase en accédant à Fichier> Paquets Swift> Ajouter un package de dépendance ...

  3. Dans l'invite qui s'affiche, sélectionnez le dépôt Firebase GitHub :

    https://github.com/firebase/firebase-ios-sdk.git
    
  4. Sélectionnez la version de Firebase que vous souhaitez utiliser. Pour les nouveaux projets, nous vous recommandons d'utiliser la dernière version de Firebase.

  5. Choisissez les produits Firebase que vous souhaitez inclure dans votre application.

Une fois que vous avez terminé, Xcode commencera à résoudre les dépendances de vos packages et à les télécharger en arrière-plan.

via Package.swift

Pour intégrer Firebase à un package Swift via un Package.swift manifeste, vous pouvez ajouter à Firebase dependencies tableau de votre colis. Pour plus de détails, consultez la documentation Package Swift Gestionnaire .

dependencies: [

  .package(name: "Firebase",
           url: "https://github.com/firebase/firebase-ios-sdk.git",
           from: "8.0"),
  // ...

],

Ensuite , dans une cible qui dépend d'un produit Firebase, l' ajouter à la dependencies tableau de cette cible.

.target(
  name: "MyTargetName",
  dependencies: [
    .product(name: "FirebaseAuth", package: "Firebase"),
    // ...
  ]
),

Considérations spécifiques au produit

Certains produits Firebase nécessitent des étapes d'intégration supplémentaires pour fonctionner correctement.

Google Analytics

Google Analytics nécessite l' ajout du -ObjC drapeau éditeur de liens pour les paramètres de construction de votre cible.

Crashlytiques

Crashlytics vous oblige à télécharger des symboles de débogage.

Vous pouvez utiliser un script d'exécution pour Xcode pour télécharger automatiquement les symboles de débogage après la construction. Trouvez le script d'exécution ici :

${BUILD_DIR%Build/*}/SourcePackages/checkouts/firebase-ios-sdk/Crashlytics/run

Une autre option pour les symboles de téléchargement est d'utiliser le upload-symbols des upload-symbols script. Placez le script dans un sous - répertoire de votre fichier de projet (par exemple des scripts/upload-symbols ), assurez - vous que le script est exécutable:

chmod +x scripts/upload-symbols

Ce script peut être utilisé pour télécharger manuellement des fichiers dSYM. Pour les notes d'utilisation et des instructions supplémentaires pour le script, exécutez upload-symbols sans aucun paramètre.