Google is committed to advancing racial equity for Black communities. See how.
ترجمت واجهة Cloud Translation API‏ هذه الصفحة.
Switch to English

البيئات المدعومة لـ Firebase JavaScript SDK

البيئات المدعومة

يتم دعم Firebase JavaScript SDK رسميًا في البيئات التالية.

المتصفحات

منتج Firebase IE11 حافة ثعلب النار كروم iOS Safari سفاري
تحليلات
المصادقة
سحابة Firestore
(إلا
إصرار)

(إلا
إصرار)

(إلا
إصرار
إذا iOS <10)
وظائف السحابة
المراسلة السحابية
(Edge 17+)
سحابة التخزين
مراقبة الاداء
قاعدة بيانات الوقت الحقيقي
التكوين عن بعد

بيئات أخرى

منتج Firebase رد الفعل الأصلي Node.js كروم
ملحقات
كوردوفا
تحليلات
المصادقة
(انظر الملاحظة )

(انظر الملاحظة )

(انظر الملاحظة )

(انظر الملاحظة )
سحابة Firestore
(إلا
إصرار)

(إلا
إصرار)
وظائف السحابة
المراسلة السحابية
سحابة التخزين
(إلا
تحميلات)
مراقبة الاداء
قاعدة بيانات الوقت الحقيقي
التكوين عن بعد

بوليفيلس

تم تصميم Firebase JavaScript SDK وفقًا لأحدث معايير النظام الأساسي للويب. لا تدعم بعض المتصفحات القديمة وبيئات JavaScript جميع الميزات المطلوبة بواسطة Firebase. إذا كان يجب عليك دعم هذه المتصفحات / البيئات ، فأنت بحاجة إلى تحميل polyfill وفقًا لذلك.

تحدد الأقسام أدناه معظم polyfills التي قد تحتاجها.

polyfills المطلوبة

البيئات بوليفيلس
أي 11 ES مستقرة
سفاري 7 و 8 و 9 ES مستقرة
العقدة <6.5 ES مستقرة

بوليفيل اختياري

البيئات بوليفيلس منتجات Firebase
  • أي 11
  • العقدة
  • سفاري <10.1
  • iOS <10.3
جلب
  • وظائف السحابة
  • مراقبة الاداء

اقترح polyfills

بوليفيلس رخصة
ES مستقرة معهد ماساتشوستس للتكنولوجيا
جلب معهد ماساتشوستس للتكنولوجيا

أضف polyfills في التطبيق الخاص بك

الخيار 1 : (موصى به) استخدم الحزم المدمج مع Babel

إذا كنت تستخدم حزمة ، فقم بالتكامل مع Babel و @ babel / preset-env للحصول على polyfills.

استخدم دليل الإعداد التفاعلي من Babel لمعرفة كيفية دمج Babel مع المجمّع الخاص بك.

مع Babel ، لا داعي للقلق بشأن polyfill الدقيق لتضمينه. بدلاً من ذلك ، تحدد الحد الأدنى من بيئات المتصفح التي تحتاج إلى دعمها. يضيف Babel ثم polyfills اللازمة لك. تضمن Babel تلبية متطلباتك الخاصة بدعم المستعرض دائمًا ، حتى إذا بدأ Firebase أو التعليمات البرمجية الخاصة بك في استخدام ميزات ES الجديدة.

لدى @ babel / preset-env معلومات مفصلة حول خيارات التكوين المتاحة لتحديد أهداف البيئة ( targets الخيارات) وإضافة useBuiltIns (option useBuiltIns ).

الخيار 2 : (غير مستحسن) إضافة polyfills يدويًا

يمكنك إضافة polyfills يدويًا باستخدام مكتبات polyfill المفضلة لديك (على سبيل المثال ، core-js ).

import 'core-js/stable'
import 'cross-fetch/polyfill';

core-js أيضًا ملف polyfill متعدد الإمكانات يمكنك تضمينه مباشرةً في صفحة HTML.

يمكن أن يكون هذا الخيار طريقة مناسبة لإدارة polyfill إذا كنت لا تستخدم Babel. ومع ذلك ، لا نوصي بخيار الكل في واحد هذا لتطبيقات الإنتاج لأنه من المحتمل أن يتضمن polyfills غير الضرورية ، مما يزيد من وزن الصفحة وبالتالي وقت تحميل الصفحة.