O Google tem o compromisso de promover a igualdade racial para as comunidades negras. Saiba como.

Solucionar problemas de opções de inicialização

Mantenha tudo organizado com as coleções Salve e categorize o conteúdo com base nas suas preferências.

Se você inicializar seu aplicativo sem um conjunto válido de opções do Firebase, novos usuários do seu aplicativo terão sérios problemas.

As opções do Firebase são um conjunto de parâmetros exigidos pelos serviços para se comunicar com sucesso com as APIs do servidor Firebase e associar dados do cliente ao seu projeto Firebase e aplicativo Firebase. Os serviços do Firebase dependem da disponibilidade de opções válidas do Firebase na biblioteca principal/comum do Firebase criada durante a inicialização do Firebase.

Diferentes serviços do Firebase exigem diferentes opções do Firebase para funcionar corretamente, mas todos os serviços do Firebase exigem as seguintes opções do Firebase:

  • Chave de API - Nota: esta não é uma chave de servidor FCM, consulte Chaves de servidor FCM .
    Valor de exemplo: AIzaSyDOCAbC123dEf456GhI789jKl012-MnO
  • ID do projeto - valor de exemplo: myapp-project-123 .
  • ID do aplicativo ("AppID") - Identificador exclusivo do seu aplicativo cujo formato depende da plataforma:
    • Para Android: mobilesdk_app_id : este não é um nome de pacote Android .
      Valor de exemplo: 1:1234567890:android:321abc456def7890
    • Para iOS+: GOOGLE_APP_ID —Observação: este não é um Apple Bundle ID .
      Valor de exemplo: 1:1234567890:ios:321abc456def7890

Solucionar problemas de aplicativos Android

Para melhorar a segurança, o SDK do Firebase foi atualizado em 27 de fevereiro e, posteriormente, substituiu o serviço Firebase Instance ID por uma dependência da Firebase Installations API .

As instalações do Firebase impõem a existência e a validade da chave de API de opções obrigatórias do Firebase, ID do projeto e ID do aplicativo para associar os dados do cliente ao seu projeto do Firebase. Consulte FirebaseOptions para obter mais informações.

Firebase Cloud Messaging (FCM) com Firebase Instance ID (IID)

Se novos usuários do seu aplicativo estiverem enfrentando problemas com o FCM, é possível que você esteja inicializando o Firebase sem o conjunto necessário de opções do Firebase.

Seu aplicativo pode estar usando um arquivo de configuração google-services.json incompleto ou incorreto; ou seu aplicativo está inicializando o Firebase programaticamente sem o conjunto completo de opções necessárias do Firebase.

Como resultado, os serviços do Firebase, como o Firebase Cloud Messaging, não funcionarão para os usuários finais que instalaram seu aplicativo depois que ele foi lançado com os SDKs do Firebase atualizados. Além disso, solicitações repetidas com falha ao Firebase podem diminuir a experiência do usuário final do seu aplicativo.

O que eu preciso fazer?

Para corrigir o mau funcionamento dos serviços do Firebase para seus aplicativos:

  1. Atualize seu aplicativo inicializando o Firebase com uma chave de API válida do seu projeto, um ID de projeto válido e um ID de aplicativo válido ( mobilesdk_app_id ou "App Id").
  2. Lance uma nova versão do seu aplicativo na Play Store.

Solucionar problemas de aplicativos da Apple

Para melhorar a segurança, o SDK do Firebase foi atualizado em 14 de janeiro e, posteriormente, substituiu o serviço Firebase Instance ID por uma dependência da Firebase Installations API .

As instalações do Firebase impõem a existência e a validade da chave de API de opções obrigatórias do Firebase, ID do projeto e ID do aplicativo para associar os dados do cliente ao seu projeto do Firebase. Consulte FIROptions para obter mais informações.

Firebase Cloud Messaging (FCM) com Firebase Instance ID (IID)

Se novos usuários do seu aplicativo estiverem enfrentando problemas com o FCM, é possível que você esteja inicializando o Firebase sem o conjunto necessário de opções do Firebase.

Seu aplicativo pode estar usando um arquivo de configuração GoogleService-Info.plist incompleto ou inválido; ou seu aplicativo está inicializando o Firebase programaticamente sem o conjunto completo de opções necessárias do Firebase.

Como resultado, os serviços do Firebase, como o Firebase Cloud Messaging, não funcionarão para os usuários finais que instalaram seu aplicativo depois que ele foi lançado com os SDKs do Firebase atualizados. Além disso, solicitações repetidas com falha ao Firebase podem diminuir a experiência do usuário final do seu aplicativo.

O que eu preciso fazer?

Para corrigir o mau funcionamento dos serviços do Firebase para seus aplicativos:

  1. Atualize seu aplicativo inicializando o Firebase com uma chave de API válida do seu projeto, um ID de projeto válido e um ID de aplicativo válido ( GOOGLE_APP_ID ou "ID do aplicativo").
    1. Processo de inicialização padrão usando um arquivo de configuração do Firebase : faça o download do arquivo de configuração GoogleService-Info.plist no console do Firebase e substitua o arquivo existente em seu aplicativo.
    2. Inicialização programática usando um objeto FIROptions : faça o download do arquivo de configuração GoogleService-Info.plist no Firebase console para encontrar sua chave de API, ID do projeto e ID do aplicativo e, em seguida, atualize esses valores no objeto FIROptions do seu aplicativo.
  2. Lance uma nova versão do seu aplicativo na App Store.

Chaves do servidor FCM

Se o seu aplicativo estiver usando uma chave do FCM Server em vez de uma chave de API do Cloud, isso pode causar uma vulnerabilidade de segurança caso você esteja usando a mesma chave do FCM Server para enviar notificações push via FCM. Nesse caso, é altamente recomendável revisar como seu servidor autentica as solicitações de envio ao FCM .

Observe que as chaves do servidor FCM (que não são iguais às chaves da API do Firebase/Cloud) não devem ser incluídas em aplicativos, pois podem ser usadas de forma abusiva para enviar notificações push no nome do seu projeto.